Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6617 - RH6.1 -> cc1 got fatal signal 11, RH -> 6.0 ok
Summary: RH6.1 -> cc1 got fatal signal 11, RH -> 6.0 ok
Keywords:
Status: CLOSED DUPLICATE of bug 5817
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: egcs
Version: 6.1
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-01 22:26 UTC by simon.greaves
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-11-02 21:07:30 UTC


Attachments (Terms of Use)

Description simon.greaves 1999-11-01 22:26:30 UTC
Hardware: Cyrix 6x86 PR200+, 64Mb RAM, 128Mb swap

I have been running RedHat on this box since (at least) 5.2,
very few problems. I previously had upgraded to 6.0 with no
real problems, I upgraded to 6.1 yesterday, no problems
during the upgrade.

I then tried to re-compile php and got serious problems with
egcs. During the make, I got seemingly random compiler
crashes, error was:

gcc: Internal compiler error: program cc1 got fatal signal
11

typing make again sometimes compiled a few more modules,
sometimes not.

I know errors of this type have been attributed to hardware
problems in the past, but I'm fairly sure that is _not_ the
case here. I noticed that the version of egcs is the same in
both RH6.1 and RH6.0, so I re-installed the older egcs
package using:

rpm --force -ivh egcs-1.1.2-12.i386.rpm

I then did a make clean and a make in the php directory and
it built without problem, so it looks like there has been a
change between egcs-1.1.2-12.i386.rpm and
egcs-1.1.2-24.i386.rpm which is causing problems (at least
for me :-).

I did not try to re-install the later version again, I will
do so and let you know if this fixes things (ie in case a
wierd dependency thing happened).

(There was a problem like this a few RedHat releases ago,
RedHat provided a special build of gcc/egcs to fix the
problem.)

I use several 'real' pentiums here at work, currently
running 6.0, I may try upgrading one, though I'm a little
apprehensive as I cannot afford much downtime. I got the 6.1
distribution from ftp.redhat.com as an iso image, md5sum was
ok, wrote it with Adaptec's Easy CD Creator on Win32, no
problems.

Any suggestions?

Thanks,

Simon

Comment 1 Jim Kingdon 1999-11-02 21:07:59 UTC
*** This bug has been marked as a duplicate of 5817 ***


Note You need to log in before you can comment on or make changes to this bug.