Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6615 - auto.master map is not checked if /etc/auto.master exists, despite autofs(8) manpage
Summary: auto.master map is not checked if /etc/auto.master exists, despite autofs(8) ...
Keywords:
Status: CLOSED DUPLICATE of bug 6484
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: autofs
Version: 6.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-01 21:59 UTC by chberg5
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-11-01 22:34:07 UTC


Attachments (Terms of Use)

Description chberg5 1999-11-01 21:59:43 UTC
autofs(8) manpage says:
After   the
       auto.master configuration file  is  processed  the
autofs
       script  will  check  for an NIS map with the same
name. If
       such a map exists then that map will be processed
in  the
       same  way as the auto.master map. The NIS map will be
pro-
       cessed last.

But that's not true, the autofs script only looks at the
auto.master map if /etc/auto.master does not exist.

The autofs-master-yp.patch patch included with the autofs
SRPM mentions this behavior.

I suggest that the behavior be modified to be compatible
with Sun's automounter, checking for a line starting with
"+" and including that map (e.g. "+auto.master"). It is
useful to be able to have both local automounter
configuration and to be able to pull the configuration from
NIS. This would be a trivial change to the autofs script.

Comment 1 Bill Nottingham 1999-11-01 22:34:59 UTC
*** This bug has been marked as a duplicate of 6484 ***


Note You need to log in before you can comment on or make changes to this bug.