Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 657 - mc doesn't show files in rpm packages
Summary: mc doesn't show files in rpm packages
Keywords:
Status: CLOSED DUPLICATE of bug 13
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mc
Version: 5.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1998-12-30 18:13 UTC by balaton
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1998-12-30 18:34:04 UTC


Attachments (Terms of Use)

Description balaton 1998-12-30 18:13:07 UTC
Something broke mc's coolest feature (according to the
package description) i.e. the ability to peek into rpm
files. When you cd into an rpm file on RedHat Linux 5.2 you
cannot see the files in it only HEADER, INSTALL, UPGRADE and
INFO. It used to work on older versions of RedHat Linux
(5.1, 5.0) with the same mc version (4.1.35).

The line that doesn't work any more in /usr/lib/mc/extfs/rpm
looks like:

rpm -qlvp $1 | sed -e 's/^\(..........\)[-t] /\1 1 /'

Removing [-t] from the above line corrects the problem, but
the same line used to work in earlier versions so the bug is
somwhere else. Maybe the output of rpm has changed (seems
not to be the case), or maybe sed has changed (this can be
the real reason, but I'm not sure).

Comment 1 David Lawrence 1998-12-30 18:34:59 UTC
*** This bug has been marked as a duplicate of 13 ***


Note You need to log in before you can comment on or make changes to this bug.