Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6567 - FTP and HTTP upgrades 6.0 -> 6.1 fail after rebuilding RPM database
Summary: FTP and HTTP upgrades 6.0 -> 6.1 fail after rebuilding RPM database
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.1
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Jay Turner
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-31 14:13 UTC by spam
Modified: 2015-01-07 23:39 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-11-01 14:41:10 UTC


Attachments (Terms of Use)

Description spam 1999-10-31 14:13:29 UTC
I have tried unsuccessfully to upgrade from RH 6.0 -> 6.1
using both FTP and HTTP. Both fail at the same location,
right after the stage where the installer rebuilds the RPM
database.

I am using the UPDATED network boot disk.

Here is the error message:

Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 225, in ?
    intf.run(todo, test = test)
  File "/tmp/lib/python1.5/site-packages/text.py", line
1000, in run
  rc = apply (step[1](), step[2])
  File "/tmp/lib/python1.5/site-packages/text.py", line 572,
in __call__
    if todo.doInstall ():
  File "/tmp/lib/python1.5/site-packages/todo.py", line
1465, in doInstall
    self.instLog = open(self.instPath + logname, "w+")
  IOError: [Errno 2] No such file or directory:
'/mnt/sysimage/tmp/upgrade.log'

Comment 1 Jay Turner 1999-11-01 14:41:59 UTC
My guess is that you have the /tmp directory symlinked to a different
location and this is causing problems with the installer.  The install
program is only able to follow relative symlinks, so I am guessing
this is an absolute symlink that you have.  Converting it to a
relative link will solve the problem.  Reopen this bug if your
problems are not solved by changing to a relative symlink.


Note You need to log in before you can comment on or make changes to this bug.