Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6516 - nfs client locks df and other things when server machine dies
Summary: nfs client locks df and other things when server machine dies
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: nfs-server
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-29 20:52 UTC by maxfield
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-10-30 13:02:58 UTC


Attachments (Terms of Use)

Description maxfield 1999-10-29 20:52:54 UTC
I have two machines, imaginatively called "one" and "nine"
:)

 nine exported / to one, with no_root_squash.

 one mounted nine under directory nine.
mount -t nfs nine:/ /nine

  nine was powered down.

  one's load went up to over 16, as users ran "df"
occasionally. df never exited. I tried to unmount /nine as
root.  That process hung forever.  I was forced to reboot
the machine.  It took quite a while for the nfs services on
one to shut down.

Comment 1 Jeff Johnson 1999-10-30 13:02:59 UTC
This is not a bug, but typical behavior when an NFS server goes down.


Note You need to log in before you can comment on or make changes to this bug.