Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6510 - set -o vi in /etc/bashrc or /etc/profile doesn't work
Summary: set -o vi in /etc/bashrc or /etc/profile doesn't work
Keywords:
Status: CLOSED DUPLICATE of bug 6084
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: bash
Version: 6.0
Hardware: alpha
OS: Linux
low
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-29 18:43 UTC by moof
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-01 20:27:34 UTC


Attachments (Terms of Use)

Description moof 1999-10-29 18:43:31 UTC
If you use the command "set -o vi" in /etc/bashrc or
in /etc/profile, then command-line editing doesn't work.
If you try and use one of the VI command to scroll through
the history list such as ESC-k k k, you just get a beep.
If you remove the "set -o vi" command from /etc/bashrc
and /etc/profile, and then type in the command from the
command line, then it works fine.

When the command is in the rc file, and you type "set -o
emacs" at the command line, then the emacs mode works.  If
you then attempt to switch to vi mode "set -o vi," then
command-line editing fails.

Comment 1 Cristian Gafton 2000-02-01 20:27:59 UTC
*** This bug has been marked as a duplicate of 6084 ***


Note You need to log in before you can comment on or make changes to this bug.