Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6501 - Cannot upgrade from 6.0 to 6.1 - installer trashes md0 partition
Summary: Cannot upgrade from 6.0 to 6.1 - installer trashes md0 partition
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jay Turner
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-29 15:15 UTC by Robert B. Westwater
Modified: 2015-01-07 23:39 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-11-30 15:55:54 UTC


Attachments (Terms of Use)

Description Robert B. Westwater 1999-10-29 15:15:11 UTC
Using two scsi drives as Raid 0. Installer does not detect
the md0 raid array. The partitions promptly get corrupted,
and I have to run fsck manually to save them.
The md0 is made from /dev/sda1 & sda2, and are mounted as
/usr.
raiddev /dev/md0
	raid-level		0
	nr-raid-disks		2
	nr-spare-disks		0
	chunk-size		4
	persistent-superblock 	1
	device			/dev/sda1
	raid-disk		0
	device			/dev/sdb1
	raid-disk		1

Comment 1 Jay Turner 1999-11-30 15:55:59 UTC
Upgrading of a RAID array is not a supported feature in 6.1 and therefore this
is not a bug.  We are adding support for upgrading RAID arrays in the next
release.

Comment 2 Robert B. Westwater 2000-02-04 17:40:59 UTC
This probable can be prevented if the partition is changed to type "fd" using
fdisk, afterwords you can run the upgrade ok?


Note You need to log in before you can comment on or make changes to this bug.