Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6500 - How to fix the blinking ADs displayed instead of hyphens..?
Summary: How to fix the blinking ADs displayed instead of hyphens..?
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: man
Version: 6.1
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
: 8574 10185 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-29 14:54 UTC by Telsa Gwynne
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-15 22:11:44 UTC


Attachments (Terms of Use)

Description Telsa Gwynne 1999-10-29 14:54:45 UTC
Very trivial, but...

I have long been plagued by glowing ADs in angle brackets
when reading man pages. Quite by chance, I found this in
'man man' as a bug, with a suggested fix of setting the
LESSCHARSET variable to 'latin1'

'man less' makes it look a bit more complicated, but this
certainly works for me. Is it possible to put this in the
/etc/profile? Or, if this would cause trouble for people
using other languages and character sets (I don't understand
all the references to locale but I gather that that's what
it's all about), is there some other way to deal with this?

Comment 1 andrewem 1999-12-10 03:42:59 UTC
The problem is indeed the "less" package not groking latin1 by default.  Putting
export LESSCHARSET=latin1 in /etc/profile is a good solution.

Another solution is to configure the man package to NOT use latin1, by editing
/etc/man.config and changing the lines with -Tlatin1 to -Tascii.  Likely won't
get some of the pretty latin1 characters displayed though.

I recommend fixing the "less" package default, or changing /etc/profile.

Comment 2 Preston Brown 1999-12-22 14:48:59 UTC
the real fix is to set your locale if you don't want to use POSIX/C/ASCII.  If I
do LANG=en_US man man, the dashes get removed.

Comment 3 Harvey Stein 1999-12-23 03:03:59 UTC
This isn't just man & less agreeing on character sets, it's everything
on the system.  For example, M-x man in emacs.  So, setting
LESSCHARSET isn't a complete solution.

The LANG=en_US fix is more global, but a) why should /etc/man.config
be arbitrarily deciding to use -Tlatin1 instead of -Tascii (as it was
in the version in RH5.2), b) does setting LANG get *all* text handling
programs to agree, and c) can you elaborate more on the effects of
setting LANG=en_US?  Your comment about setting it "if you don't want
to use POSIX/C/ASCII" makes me a little nervous.

Also, is this going to be corrected in RH6.2, and if so, is it going
to be via setting LANG by default in /etc/profile?

Comment 4 Bill Nottingham 2000-02-05 20:01:59 UTC
*** Bug 8574 has been marked as a duplicate of this bug. ***

Comment 5 Cristian Gafton 2000-02-15 22:11:59 UTC
echo LANG=en_US > /etc/sysconfig/i18n

That _is_ the proper fix.

And yes, it will be fixed in the next release

Comment 6 Tony Krch 2000-03-16 00:01:59 UTC
*** Bug 10185 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.