Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6494 - [text mode] anaconda exception on 'SERVER' key after selecting video chipset CTB9000
Summary: [text mode] anaconda exception on 'SERVER' key after selecting video chipset ...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jay Turner
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-29 12:45 UTC by James Manning
Modified: 2015-01-07 23:39 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-08 19:28:23 UTC


Attachments (Terms of Use)

Description James Manning 1999-10-29 12:45:20 UTC
Netfinity 4000R (Intimidator, the 1U dual PIII box)

Selected "Install Custom system" (text mode from cd-rom)
sda => 8000MB /, 643MB swap
sdb => 4337MB /tmp, 4337MB /usr/local
selected "Everything" for installer (in a rush)
mouse => generic 3-button ps/2 (no emul necessary)
video chipset => selected Chips and Technologies CTB9000
   based on video desc from http://www.pc.ibm.com/
   of "Chips in Technology B6 9000" (closest match)
exception occurs here, as follows:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 225, in ?
    intf.run(todo, test = test)
  File
"../../../RedHat/instimage/usr/lib/python1.5/site-packages/text.py",
line 1000, in run
    rc = apply(step[1](), step[2])
  File
"../../../RedHat/instimage/usr/lib/python1.5/site-packages/text.py",
line 534, in __call__
    todo.x.setVidcard (card)
  File
"../../../RedHat/instimage/usr/lib/python1.5/site-packages/xf86config.py",
line 154, in setVidcard
    self.server = self.vidCards[0]["SERVER"]
KeyError: SERVER

A "p self.vidCards[0]" in the debugger shows the
chipset support was (correctly?) aliased to the
'Chips & Technologies CT65530', with a well-populated array
including 'SEE' 'NAME', a long 'LINE' entry, etc but no
'SERVER' key.

Perhaps just a missing 'SERVER' => 'SVGA' or similar
in some chipset config file?

Comment 1 Jay Turner 1999-11-30 15:59:59 UTC
*** Bug 6765 has been marked as a duplicate of this bug. ***

Comment 2 Jay Turner 1999-11-30 16:00:59 UTC
This issue has been assigned to a developer for further action.

Comment 3 James Manning 1999-11-30 20:23:59 UTC
lspci -v of the video card:
01:00.0 VGA compatible controller: Chips and Technologies: Unknown device 00c0
(rev 64)
        Subsystem: Unknown device 102c:00c0
        Flags: stepping, medium devsel
        Memory at fd000000 (32-bit, non-prefetchable)

This maps to kudzu/pcitable entry of:
0x102c  0x00c0  "unknown"       "C&T|F69000 HiQVideo"

Since neither Card: nor Server: is specified, it makes sense that
the GUI install and the XF86 configuration don't work, right?  I can't find
the /usr/X11R6/lib/X11/Cards database it uses, so I'll have to assume
that something in there is what was aliasing the card to CT65530

Comment 4 Jay Turner 2000-02-08 19:28:59 UTC
Fixed in the latest RawHide.


Note You need to log in before you can comment on or make changes to this bug.