Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6459 - Erratic mouse movement with Voodoo Banshee hardware
Summary: Erratic mouse movement with Voodoo Banshee hardware
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
: 9667 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-28 10:51 UTC by flavio
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-06-26 02:45:14 UTC


Attachments (Terms of Use)

Description flavio 1999-10-28 10:51:31 UTC
Mouse movement is erratic under certain conditions (as
activity in some windows, network activity, etc.) under
XFree86 with a Voodoo Banshee video card (probably with a
Voodoo 3 too). This bug did not appear in RedHat 6.0 with
XFree86 3.3.5 (taken from RedHat 6.1).

Comment 1 keith 1999-11-24 09:59:59 UTC
I'm getting the same with an ATI Expert 98 & Voodoo 2 & Logitech MouseMan,
normally when lots of IO is happening in the background (e.g. copying a 200 meg
file from one partition to another). Under RH5.2 this type of operation didn't
affect mouse movement. A look at the gnome cpu graph shows all the time is
in 'nice'.

Comment 2 Preston Brown 2000-02-04 16:34:59 UTC
make sure you don't have option sw_cursor turned on in /etc/X11/XF86Config.
Alternatively, try out XFree86 3.3.6 from our rawhide tree and see if it fixes
your problem.

We can't duplicate the problem here.

Comment 3 aicowan 2000-02-14 15:40:59 UTC
I am using a Quantum Raven 3D PCI card that runs with the latest Banshee drivers
under Windows 98/direct X7.0 (dual boot machine). Redhat recognises it as a
Banshee and all the install goes great except that whenever I move the mouse
toward a button e.g. the "Add Comment" on this form the mouse pointer dissapears
and re-appears at a random location on the screen. This happens during install
as well as in both Gnome and KDE (at all res's). I just did a Vanilla install
from the RH6.1 CD and have so far applied no patches.
My mouse is a Rockwell PS/2 (Ms Wheel Mouse clone).

Is this the same problem as outlined by keith@bssl.co.uk??

Comment 4 Preston Brown 2000-02-23 20:19:59 UTC
*** Bug 9667 has been marked as a duplicate of this bug. ***

Comment 5 Andrew Spyker 2000-06-26 02:45:14 UTC
Hello,

This bugged me beyond belief.  I tired a bunch of PS/2 mice I had laying around
and they all exhibitted the same behavior.  I found the following post on
usenet.  It turned out to be a problem with the bios of my MB.  Three people
have said this fixed the problem.  I also am very happy to say it fixed me. 
BTW, this affected the shipping BIOS on a ABIT KA7/KA7-100 MB.

http://x55.deja.com/viewthread.xp?AN=628679020&search=thread&svcclass=dnserver&ST=PS&CONTEXT=961986966.1466957927&HIT_CONTEXT=961986966.1466957927&HIT_NUM=4&recnum=%3c8gua3t$3fa$1@news.flashnet.it%3e%231/1&group=alt.comp.mainboards.abit&frpage=getdoc.xp&back=clarinet

Comment 6 Preston Brown 2000-06-26 19:19:35 UTC
thank you very much for finding the solution to this problem.


Note You need to log in before you can comment on or make changes to this bug.