Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 645563 - GFS2: glock with no holder
Summary: GFS2: glock with no holder
Keywords:
Status: CLOSED DUPLICATE of bug 595397
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel
Version: 5.5.z
Hardware: Unspecified
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Robert Peterson
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-10-21 20:25 UTC by Anton Mark
Modified: 2018-11-14 17:31 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-10 15:45:42 UTC
Target Upstream Version:


Attachments (Terms of Use)
gfs2_hangalyzer output showing lost locks (deleted)
2010-10-21 20:25 UTC, Anton Mark
no flags Details

Description Anton Mark 2010-10-21 20:25:45 UTC
Created attachment 454927 [details]
gfs2_hangalyzer output showing lost locks

Description of problem:
Customer reported GFS2 IO freeze.  Running gfs2_hangalyzer reports pid waiting for glock but no holder found.

Version-Release number of selected component (if applicable):
RHEL 5.5.z

How reproducible:
Customer generally ran in to this problem once a week.

Steps to Reproduce:
Details are not known yet exactly how to make it happen.  It seems to have to do with active/active mail server workload.

Actual results:
All IO on a specific GFS2 file system would eventually stop (or at least appear to stop).

Expected results:
IO doesn't stop.

Additional info:
Will attach gfs2_hangalyzer output with missing locks.  Gave customer 2.6.18-209.el5.x86_64.rpm test kernel and this appears to have fixed the lost locks part of this.

Comment 1 Robert Peterson 2010-11-08 17:45:05 UTC
This may be a duplicate of bug #595397.

Comment 2 Ben Turner 2010-11-10 15:45:42 UTC

*** This bug has been marked as a duplicate of bug 595397 ***


Note You need to log in before you can comment on or make changes to this bug.