Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6452 - lance module oops on unloading
Summary: lance module oops on unloading
Keywords:
Status: CLOSED DUPLICATE of bug 4939
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-28 06:46 UTC by Oleg Makarenko
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-11-04 23:31:00 UTC


Attachments (Terms of Use)

Description Oleg Makarenko 1999-10-28 06:46:43 UTC
Description
Network driver lance.o unconditionaly oops on rmmod or auto
unloading.

The same was true with RH6.0

Conclusion.
The following patch works for me.

--- drivers/net/lance.c.orig    Mon Aug  9 23:04:39 1999
+++ drivers/net/lance.c Wed Oct 27 22:07:16 1999
@@ -349,11 +349,11 @@
        for (this_dev = 0; this_dev < MAX_CARDS; this_dev++)
{
                struct device *dev = &dev_lance[this_dev];
                if (dev->priv != NULL) {
-                       kfree(dev->priv);
-                       dev->priv = NULL;
                        free_dma(dev->dma);
                        release_region(dev->base_addr,
LANCE_TOTAL_SIZE);
                        unregister_netdev(dev);
+                       kfree(dev->priv);
+                       dev->priv = NULL;
                }
        }
 }

Comment 1 Bill Nottingham 1999-11-04 23:31:59 UTC
*** This bug has been marked as a duplicate of 4939 ***


Note You need to log in before you can comment on or make changes to this bug.