Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6450 - ncftp-3.0beta21-2 doesn't seem to work with runsocks
Summary: ncftp-3.0beta21-2 doesn't seem to work with runsocks
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: ncftp
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-28 05:30 UTC by dunwoody
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-11-22 17:33:19 UTC


Attachments (Terms of Use)

Description dunwoody 1999-10-28 05:30:47 UTC
I've been using runsocks-1.0r9-6 with ncftp to access ftp
sites from behind SGI's firewall.  Up to and including
ncftp-3.0beta19-2, this worked fine.  With
ncftp-3.0beta21-2, I get "bad file descriptor" errors:

------------------------------------------------------------dunwoody1:rpm>
runsocks ncftp rawhide.redhat.com
NcFTP 3.0.0 beta 21 (October 04, 1999) by Mike Gleason
(ncftp@ncftp.com).
Resolving
rawhide.redhat.com...
Connecting to
208.178.165.228...
Could not open host rawhide.redhat.com: invalid reply from
server.
Could not read reply from control connection: Bad file
descriptor
------------------------------------------------------------

I switched back and forth between ncftp-3.0beta19-2 and
ncftp-3.0beta21-2 just to convince myself this wasn't
a transient error, and it consistently works fine with
beta19-2 and breaks with beta21-2.

I do NOT get these errors using beta21-2 with a direct
Internet connection (no runsocks/firewall).

This might be a problem that's peculiar to my network
environment, but since ncftp is probably used frequently
with socks to get through firewalls, I thought I should
report it.

Comment 1 Bernhard Rosenkraenzer 1999-11-22 17:33:59 UTC
Can't reproduce it here... Does it happen with every ftp server or only with
ones running wu-ftpd 2.6.0?

Comment 2 dunwoody 2000-02-13 05:08:59 UTC
Just to provide a further sense of closure on this one, the problematic behavior
I was seeing seems to have disappeared with the combination of ncftp-3.0beta21-2
and the latest Rawhide rpm's as of this writing.


Note You need to log in before you can comment on or make changes to this bug.