Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6442 - Disk Druid automatic tagging of drive for format
Summary: Disk Druid automatic tagging of drive for format
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.1
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Jay Turner
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-28 04:13 UTC by egalanos.
Modified: 2015-01-07 23:39 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-10-29 17:48:36 UTC


Attachments (Terms of Use)

Description egalanos. 1999-10-28 04:13:14 UTC
ext2 partitions tha exist previous to installation, and are
then selected as mount points in disk druid are
automatically tagged by disk druid to be formated on the
next screen. This is really bad, if the drive has existing
data on it, and a person accidentally does not deselect the
format (lucky I didn't :)

Comment 1 Jay Turner 1999-10-29 17:48:59 UTC
It is recommended that all partitions be formatted prior to use under
linux, and this is why the partitions default to the check mark.
There is a larger group of people that would forget to check those
boxes to format the partitions than would forget to uncheck the box to
prevent formatting, so the Red Hat installer defaults to formatting
ext2 filesystems.  This is not a bug as it is the desired behavior of
the installer.

Comment 2 landon 2000-01-23 02:06:59 UTC
Not a bug?  Maybe not if you define bug as "programming error", but in my
strong opinion, this is a clear design flaw.

Although, I suppose I am biased, having just wiped out several gigs of
personal files.

Please, PLEASE give more feedback to the user when you are about to format
a partition.  Whenever partitions are to be formatted, a screen should be
presented indicating in large text what is to be formatted, and requiring
the user to acknowledge before continuing.

Please, reopen this ticket and do something about it.  I don't want anyone
else to go through the agony that I just experienced, and such poor design
does not reflect well on RedHat.


Note You need to log in before you can comment on or make changes to this bug.