Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6419 - kickstart upgrade with %packages installs only these
Summary: kickstart upgrade with %packages installs only these
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Erik Troan
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-27 12:23 UTC by Stelian Pop
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-13 13:37:46 UTC


Attachments (Terms of Use)

Description Stelian Pop 1999-10-27 12:23:25 UTC
If I make a kickstart upgrade, with the kickstart file
containing a %package section, I would like to:
- upgrade all the install packages, regardless of my
  %packages section
- install (or upgrade if already present) the packages
  specified in the %packages section.

Instead of this, only the last is made. Old packages that
are installed but not mentioned in %package section do not
get upgraded (even if a newer version exists on the install
media).

I believe this is not the way %packages should be treated.

Stelian.

Comment 1 Jay Turner 1999-10-29 18:21:59 UTC
This issue has been assigned to a developer for further action.

Comment 2 Erik Troan 2000-01-31 19:50:59 UTC
%packages shouldn't be used w/ kickstart upgrades; it's behavior is
currently undefined

Comment 3 Stelian Pop 2000-02-01 09:47:59 UTC
I'm afraid this response is not sufficient for marking the bug 'NOTABUG' !!!

This must be qualified as a documentation bug or a request for enhancement.

I would prefer the second one, because I think this is the way a kickstart
upgrade should work (a new version of RedHat Linux contains upgraded versions
of older packages but it contains also new packages, which I would like to
install. The GUI installer also leave the choice to 'customize the packages'
to install. This should be present also in the kickstart upgrade! Without this,
the kickstart upgrade is somewhat usefulness...).

Thanks for reopening the bug.

Stelian.
this kin

Comment 4 Stelian Pop 2000-02-04 16:33:59 UTC
Excuse me, but someone marked this bug as 'FIXED'...

Does this mean that the 'request for enhancement' was accepted, implemented
and released (where? Rawhide, next version? I thought that you have special
resolution names for these).

A small comment indicating what have you done it's necessary in order
to understant how did you FIX that.

Ok, so I'm reopening the bug :)

Stelian.

Comment 5 Erik Troan 2000-02-13 13:37:59 UTC
It means that it's working as designed.We've marked this as a feature request for future releases.


Note You need to log in before you can comment on or make changes to this bug.