Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6412 - bind init scripts hoased
Summary: bind init scripts hoased
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: bind
Version: 6.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
: 6411 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-27 08:40 UTC by jes.sorensen
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-10-27 19:15:35 UTC


Attachments (Terms of Use)

Description jes.sorensen 1999-10-27 08:40:30 UTC
Hi

It looks like bind in Red Hat 6.1 comes with incorrect init
scrupts. Ie.

[jes@pcitpdp17 jes]$ rpm -qlp bind-8.2.1-7.i386.rpm
/etc/logrotate.d/named
/etc/rc.d/init.d/named
/etc/rc.d/rc0.d/K45named
/etc/rc.d/rc1.d/K45named
/etc/rc.d/rc2.d/K45named
/etc/rc.d/rc3.d/K45named
/etc/rc.d/rc4.d/K45named
/etc/rc.d/rc5.d/K45named
/etc/rc.d/rc6.d/K45named

named is never launched after a boot, in 6.0 rc[345].d had
S55named instead of K45named

Jes

Comment 1 Bill Nottingham 1999-10-27 14:41:59 UTC
This was a (regrettably, pretty much undocumented) policy change.

The general philosophy was to have more servers, especially ones
that require extra configuration, off by default, as it increases
security. This includes bind, innd, dhcpd, samba, amd, and knfsd.

In theory, user's settings with chkconfig would get preserved on
upgrade, but this didn't happen with bind because it's one of the
packages that also includes the links in the package.

Of course, to turn it on, you can do:

chkconfig --level 345 bind on

or, just use ntsysv.

Comment 2 Bill Nottingham 1999-11-04 20:21:59 UTC
*** Bug 6411 has been marked as a duplicate of this bug. ***

When you upgrade from 8.2 to 8.2.1 then your DNS will be
disabled wich is NOT the way I think.
It should leave the old settings intact and only disable or
better said not-enable when first installing this package.
It took me a serious search why some programs didn't work
anymore because the DNS wasn't started...

PS:
I get a strange msg when querying the status:
-=-=-=-=-=-
/etc/rc.d/init.d/named status
named 8.2.1 Tue Oct 12 21:49:04 EDT 1999
root@porky.devel.redhat.com:/usr/src/bs/BUILD/bind-8.2.1/src/bin/named
number of zones allocated: 64
debug level: 0
xfers running: 0
xfers deferred: 0
soa queries in progress: 0
query logging is ON
server is DONE priming
server IS NOT loading its configuration
-=-=-=-=-=-
It's this last msg about NOT loading its configuration, what
does that mean and what should I do to correct it?
The process is starting ok now that I've enabled it with
"chkconfig"...


Note You need to log in before you can comment on or make changes to this bug.