Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 641 - Please add ru_RU.KOI8-R locale
Summary: Please add ru_RU.KOI8-R locale
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc
Version: 5.2
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
: 755 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1998-12-29 01:10 UTC by Aleksey Nogin
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-08-30 21:05:25 UTC


Attachments (Terms of Use)

Description Aleksey Nogin 1998-12-29 01:10:58 UTC
The de-facto standard for Russian Cyrillics on Linux (and
other Unices) is a KOI8-R encoding while virtually nobody
uses ISO-8859-5 for Russian. But the glibc RPM includes
/usr/share/locale/ru_RU directory with ru_RU.ISO-8859-5 and
does not include ru_RU.KOI8-R locale

Comment 1 Cristian Gafton 1998-12-30 00:49:59 UTC
The glibc rpms are including the KOI*-R support, but under the name of
ru_SU. You can either use ru_SU instead of the ru_RU or just replace
the contents of the ru_RU dirs/locale files with what is found in
ru_SU

Needless to say, the "international standard" is the ISO-8859-5 crap
for ru_RU and we can not diverge that easily from the standards...

Now, if the ru_SU thing is busted then I am taking patches, my russian
is *so* limited...
:-)

Comment 2 Aleksey Nogin 1998-12-30 01:30:59 UTC
/usr/share/locale/ru_SU seems OK, I just did not know it was KOI8-R

But there is a big problem with ru_SU -
/usr/X11R6/lib/X11/locale/locale.alias defines ru_SU to be
ru_RU.ISO-8859-5

One way to make everything work consistently (and without any
deviation from standards) is to run

cd /usr/share/locale
localedef -ci ru_RU -f KOI8-R ru_RU.KOI8-R
mv ru_RU.koi8r ru_RU.KOI8-R

and to use LC_ALL=ru_RU.KOI8-R after that.


Another way is to add

ru_RU.KOI8-R    ru_SU

line to /usr/share/locale/locale.alias and to change ru_SU to be
ru_RU.KOI8-R in /usr/X11R6/lib/X11/locale/locale.alias

One of the problems with the second approach is that neither
locale.alias file is a %config file

Comment 3 David Lawrence 1999-01-12 23:47:59 UTC
*** Bug 641 has been marked as a duplicate of this bug. ***

Traditionaly, *the standard* locale for UNIX in Russia was
KOI8-R. This is broken in RedHat - ISO is set by default.

To fix:

1. ru_RU must select KOI8-R
   (same in /usr/X11R6/lib/X11/locale/locale.alias)

2. ru_RU.<charset> must reference respective charsets

3. ru_SU must be an alias for ru_RU

Comment 4 Preston Brown 1999-03-22 18:53:59 UTC
ru_SU now properly selected KOI8-R.  The X situation has been
rectified as well.

Comment 5 Preston Brown 1999-08-30 21:04:59 UTC
correction:

for 6.1, ru_SU is gone.  ru_RU selects ISO-8859-5.  ru_RU.KOI8-R
selected the KOI8-R encoding, and ru_RU.ISO-8859-5 selects the 8859-5
encoding as well (obviously).

We are fully in line with all standards for this.


Note You need to log in before you can comment on or make changes to this bug.