Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6408 - wu-ftpd-2.6.0-1.i386.rpm + ftp install = signal 11
Summary: wu-ftpd-2.6.0-1.i386.rpm + ftp install = signal 11
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.0
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact:
URL:
Whiteboard:
: 6689 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-27 02:23 UTC by Nick Urbanik
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-15 16:33:11 UTC


Attachments (Terms of Use)

Description Nick Urbanik 1999-10-27 02:23:00 UTC
Our RH 6.0 server runs on a Cyrix P166+ CPU, and had all
updates installed.  When I tried installing RH 6.1 by ftp,
the process was extaordiarily slow (was successful
previously).  The log contained many messages like this:

Oct 27 01:01:31 www ftpd[3586]: ANONYMOUS FTP LOGIN FROM
daniel.tyee.vtc.edu.hk [192.168.129.222],
anonymous@localhost.localdomain
Oct 27 01:03:48 www ftpd[3521]: exiting on signal 11
Oct 27 01:15:34 www ftpd[3568]: exiting on signal 11

The results were installation processes that were due to
finish in 250 hours after 14 hours had already elapsed!

When I downgraded back to wu-ftpd-2.5.0-5.6.0.i386.rpm, the
problem disappeared, and the upgrade process sped up
immensely.  I restarted the other installation and that is
now going smoothly as before.  So what is wrong?  Perhaps a
rpm --rebuild wu-ftpd-2.6.0-1.src.rpm might do the
trick.

Comment 1 Pekka Savola 1999-11-01 11:09:59 UTC
This is related to the bug 6385.

We are experiencing exactly the same symptoms.  FTP Installs fail
with 'Error setting remote server to passive mode', and downgrading
the ftp server removes the problem immediately.

Recompiling from .srpm didn't work (as bug report 6385 points out).

I'd recommend you release updated wu-ftpd packages ASAP and fix the
broken clients.  Working FTP installs are pretty vital :)

Comment 2 jeremy 2000-01-14 16:04:59 UTC
Same problem here installing from a local mirror. At the time of error there
were no other ftp connections and system load as under .05. A sniff trace
revealed a second PASV call after hdlist retrieval. Here are the first two file
retrievals (that were successful):

USER anonymous
PASS root@
TYPE I
PASV
RETR /pub/kickstart/redhat-6.0/i386/RedHat/base/hdlist
PASV

USER anonymous
PASS root@
TYPE I
PASV
RETR /pub/kickstart/redhat-6.0/i386/RedHat/base/stage2.img
PASV

As you can see, there is a second PASV call. I don't know why that should
make any sort of difference, but it's the only thing I see between the two
that is different at all.

As others have stated, downgrading to wu-ftpd 2.5.0 using the same configuration
immediately fixes the problem.

Comment 3 Bernhard Rosenkraenzer 2000-01-18 15:19:59 UTC
*** Bug 6689 has been marked as a duplicate of this bug. ***

Comment 4 Bernhard Rosenkraenzer 2000-01-18 15:24:59 UTC
wu-ftpd 2.6.0 no longer supports broken clients (and compiling it with support
for broken clients would be a bad idea because it would break the ftp protocol,
see http://www.wu-ftpd.org/broken-clients.html for details).
This is actually a bug in the installer for not speaking the correct ftp
protocol; reassigning the bug.

Comment 5 Jay Turner 2000-02-08 19:12:59 UTC
Dr. Mike, this is definitely something that we will want to play with in the lab
and let everyone know what version of wu-ftp is working with the installer.

Comment 6 Jay Turner 2000-02-15 16:33:59 UTC
Issue is resolved in the next RawHide.


Note You need to log in before you can comment on or make changes to this bug.