Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6402 - upgrade fails with Python traceback
Summary: upgrade fails with Python traceback
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-26 23:20 UTC by culliton
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-10-29 18:37:27 UTC


Attachments (Terms of Use)

Description culliton 1999-10-26 23:20:27 UTC
When upgrading from 6.0 to 6.1, possibly associate with some
kind of mount error, definitely associated with customizing
the list of packages to be installed, I got the following
python traceback from the (very slick) new installer:

Gdk-WARNING **: shmget failed!
Exception in thread Thread-3:
Traceback (innermost last):
  File "/usr/lib/python1.5/threading.py", line 376 in
__bootstrap (? handwriting is garbled)
    self.run()
  File "/usr/lib/python1.5/site-packages/iw/progress.py",
line 16, in run
    rc = self.todo.doInstall()
  File "/usr/lib/python1.5/site-packages/todo.py", line 1512
in doInstall
    prob = "%-15s %d %c\n" % (mount, need, suffix)
TypeError: illegal argument type for builtin operation

Comment 1 culliton 1999-10-26 23:28:59 UTC
BTW - This is with the latest boot image from updates.rdehat.com and a
local CD install.

Comment 2 culliton 1999-10-26 23:46:59 UTC
This may be a duplicate of #5809.  Apologies.  It takes a while to
learn how to search for existing reports, you really have to submit
one yourself to figure it out.

Comment 3 Jay Turner 1999-10-29 18:37:59 UTC
*** This bug has been marked as a duplicate of 5809 ***


Note You need to log in before you can comment on or make changes to this bug.