Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6388 - fork man page
Summary: fork man page
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: man-pages
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-26 16:01 UTC by bcurran
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-05-30 18:01:15 UTC


Attachments (Terms of Use)

Description bcurran 1999-10-26 16:01:54 UTC
The man page for fork shows that it needs the unistd.h
header file.  This should be changed to sys/types.h.  A test
compile shows this:


#include <unistd.h>

int bozo(void)
{
	pid_t ret;
	ret = fork();
}


The compile line is: gcc -D_POSIX_SOURCE -c foo.c

> gcc -v
Reading specs from
/usr/lib/gcc-lib/i386-redhat-linux/egcs-2.91.66/specs
gcc version egcs-2.91.66 19990314/Linux (egcs-1.1.2 release)

Comment 1 Bernhard Rosenkraenzer 2000-02-17 20:03:59 UTC
Alternatively, use __pid_t instead of pid_t - fork itself doesn't need
sys/types.h.

Comment 2 Cristian Gafton 2000-05-22 15:02:59 UTC
assigned to teg

Comment 3 Trond Eivind Glomsrxd 2000-05-30 18:01:59 UTC
Not a bug - fork needs only unistd.h.  You don't need to use the type
directly...


Note You need to log in before you can comment on or make changes to this bug.