Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 636041 - Rename pycairo to python-cairo for Fedora 15.
Summary: Rename pycairo to python-cairo for Fedora 15.
Keywords:
Status: CLOSED DUPLICATE of bug 731891
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Miroslav Suchý
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: FE-DEADREVIEW
TreeView+ depends on / blocked
 
Reported: 2010-09-21 11:48 UTC by Matthew Barnes
Modified: 2013-10-20 03:26 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-04 16:34:09 UTC


Attachments (Terms of Use)

Description Matthew Barnes 2010-09-21 11:48:27 UTC
As of version 1.8.10, the upstream pycairo project has begun releasing two tarballs: pycairo for Python 3, and py2cairo for Python 2.  Unfortunately, prior to version 1.8.10 the tarball releases for Python 2 were also called "pycairo".  In order to provide a smooth upgrade path for Python 2 users, we now need to deviate from upstream tarball names.

J5 and I agreed to rename the pycairo package for Python 2 to "python-cairo", and introduce a new "python3-cairo" package for Python 3.

http://mbarnes.fedorapeople.org/python-cairo.spec
http://mbarnes.fedorapeople.org/python-cairo-1.8.10-1.fc15.src.rpm

Comment 1 Miroslav Suchý 2010-11-01 19:29:07 UTC
python-cairo.src: W: strange-permission py2cairo-1.8.10.tar.gz 0444L
This should be probably 644

python-cairo.src: E: invalid-spec-name
http://fedoraproject.org/wiki/Packaging/NamingGuidelines#Spec_file_name
Your spec is named pycairo.spec, whereas you should use python-cairo.spec

not sure, why you use %{cairo_version}, which is the same as %{version}

there is huge list of rpmlint warning such as:
python-cairo.x86_64: W: spurious-executable-perm /usr/share/doc/python-cairo-1.8.10/examples/cairo_snippets/snippets/set_line_join.py
The file is installed with executable permissions, but was identified as one
that probably should not be executable.  Verify if the executable bits are
desired, and remove if not.
I would tend to think that files in /usr/share/doc should not have executable bits sets. But I will not block review on this.

beside mention items it looks good. Please fix at least first two.

Comment 2 Matthew Barnes 2010-12-17 11:26:05 UTC
(In reply to comment #1)
> python-cairo.src: W: strange-permission py2cairo-1.8.10.tar.gz 0444L
> This should be probably 644

I'll fix the tarball permission the next time I upgrade the package.


> Your spec is named pycairo.spec, whereas you should use python-cairo.spec

I linked to python-cairo.spec but forgot to change it in the uploaded source package.  I'll fix it when I actually rename the package.

 
> not sure, why you use %{cairo_version}, which is the same as %{version}

That's true for 1.8.10, but isn't necessarily always true.  "cairo_version" refers to the minimum version of cairo needed to build the Python bindings for cairo.

 
> there is huge list of rpmlint warning such as:
> python-cairo.x86_64: W: spurious-executable-perm
> /usr/share/doc/python-cairo-1.8.10/examples/cairo_snippets/snippets/set_line_join.py
> The file is installed with executable permissions, but was identified as one
> that probably should not be executable.  Verify if the executable bits are
> desired, and remove if not.
> I would tend to think that files in /usr/share/doc should not have executable
> bits sets. But I will not block review on this.

I can't reproduce these warnings.  All installed files use %defattr(-,root,root,-).

Comment 3 Miroslav Suchý 2011-08-08 14:04:46 UTC
ping. 
any progress?

Comment 4 Miroslav Suchý 2011-11-22 19:52:59 UTC
ping. 
any progress?

Comment 5 Miroslav Suchý 2012-08-04 16:34:09 UTC
Closing as submiter is not responding.

Comment 6 Christopher Meng 2013-10-20 03:26:28 UTC

*** This bug has been marked as a duplicate of bug 731891 ***


Note You need to log in before you can comment on or make changes to this bug.