Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 634588 - can not specify year in "Custom Cron format" in Channel Repositories Sync schedule
Summary: can not specify year in "Custom Cron format" in Channel Repositories Sync sch...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server
Version: 540
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Justin Sherrill
QA Contact: Tomas Lestach
URL:
Whiteboard:
Depends On:
Blocks: sat540-canfix
TreeView+ depends on / blocked
 
Reported: 2010-09-16 13:16 UTC by Jan Hutař
Modified: 2010-10-28 14:48 UTC (History)
3 users (show)

Fixed In Version: spacewalk-java-1.2.39-9.el5sat
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-10-28 14:48:06 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jan Hutař 2010-09-16 13:16:07 UTC
Description of problem:
I have tried to use various examples of Quarts cron format and was not able to specify year.

http://www.quartz-scheduler.org/docs/tutorials/crontrigger.html


Version-Release number of selected component (if applicable):
Galactica 20100910.2
quartz-1.8.1-3.el5sat
spacewalk-taskomatic-1.2.35-1.el5sat


How reproducible:
1 of 1 satellite


Steps to Reproduce:
1. Create repos and channel, assign some repo(s) to the channel
2. Go to Channels -> Manage Software Channels -> <channel> -> Repositories -> Sync -> Custom Cron format:
3. Enter "0 15 10 ? * * 2011" (~ every day in 10:15 in year 2011) and click on "Schedule"


Actual results:
Red warning saying: "Invalid schedule entry: 0 15 10 ? * * 2011"


Expected results:
Should work or there should be a link to supported formats of input

Comment 1 Clifford Perry 2010-09-16 15:01:36 UTC
This would be nice to have fixed. I don't see us blocking release for it. I assume this is mostly functional, but some syntax is not available. We may want to do kbase initially for customers on accepted input.


Cliff

Comment 2 Jan Hutař 2010-09-17 06:40:55 UTC
Another not accepted input from Quarz examples:

0 15 10 ? * 6#3   Fire at 10:15am on the third Friday of every month
0 0 12 1/5 * ?	  Fire at 12pm (noon) every 5 days every month, starting on
                  the first day of the month.
0 11 11 11 11 ?	  Fire every November 11th at 11:11am.

Comment 3 Justin Sherrill 2010-09-23 22:49:46 UTC
I believe my fixes for 634834 already fixed this, as I am not able to reproduce with my current devel setup or with spacewalk-java-1.2.39-9.el5sat which was built on the 21st.

Comment 5 Tomas Lestach 2010-10-06 11:18:57 UTC
All of the stated cron expressions are now accepted:

0 15 10 ? * * 2011
0 15 10 ? * 6#3
0 0 12 1/5 * ?
0 11 11 11 11 ?

I tested following cron expressions (similar to those reported in the BZ) and verified the repository got synced:

0 48 05 ? * * 2010    5:48 every day during 2010
0 08 6 ? * 4#1        06:08 every 1st Thr every month
0 15 6 1/5 * ?        06:15 every 5 days every month starting on the 1st day of the month
0 17 6 6 10 ?         06:17 on 6th of Oct every year

VERIFIED with spacewalk-java-1.2.39-26.el5sat on Satellite-5.4.0-RHEL5-re20101001.1

Comment 8 Michael Mráka 2010-10-21 09:50:36 UTC
Verified in stage.

Expressions from comment #5 work.

Comment 9 Clifford Perry 2010-10-28 14:43:24 UTC
The 5.4.0 RHN Satellite and RHN Proxy release has occurred. This issue has been resolved with this release. 


RHEA-2010:0801 - RHN Satellite Server 5.4.0 Upgrade
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10332

RHEA-2010:0803 - RHN Tools enhancement update
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10333

RHEA-2010:0802 - RHN Proxy Server 5.4.0 bug fix update
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10334

RHEA-2010:0800 - RHN Satellite Server 5.4.0
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10335

Docs are available:

http://docs.redhat.com/docs/en-US/Red_Hat_Network_Satellite/index.html 

Regards,
Clifford


Note You need to log in before you can comment on or make changes to this bug.