Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6335 - gnorpm crashes when preferences-dialog is selected
Summary: gnorpm crashes when preferences-dialog is selected
Keywords:
Status: CLOSED DUPLICATE of bug 6534
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnorpm
Version: 6.1
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Matt Wilson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-25 14:04 UTC by qualita
Modified: 2008-05-01 15:37 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-05 19:37:49 UTC


Attachments (Terms of Use)

Description qualita 1999-10-25 14:04:04 UTC
Any tentative to select a preference in gnorpm pref. dialog
box causes a segmentation fault.

Comment 1 maavl 1999-11-23 11:38:59 UTC
I've had this too. It seems to be caused by the fact that gnorpm wishes to get
loads of files (aparently desribing the current status of the redhat
distribution) off the net, and it cannot handle the case that the internet is
not reachable. Opening a ppp connection before selecting the pref dialog (and
leaving it open until gnorpm had finished downloading) solved the problem for
me. It still is serious a bug, and gnorpm should at least warn clearly
beforehand that it needs to access the net. I also think that tools should not
depend on network connectivity unless the can demonstrate that this is an
absolute necessity. And why can gnorpm not be shipped with the necessary files
as of the date of distribution (once you've got the files, gnorpm won't try to
get them again until a certain delay expires; you can set that delay IF you
manage to open the pref dialog...).

Comment 2 maavl 1999-11-23 11:52:59 UTC
Bugs 5523, 5721, 6335 (this one) and 6888 are duplicates (any more takers?).

Comment 3 Gregory McLean 1999-12-31 18:59:59 UTC
Well I can confirm this also, except my machine has a 24x7 net connection and it
still does it.

Comment 4 Bill Nottingham 2000-02-05 19:37:59 UTC
*** This bug has been marked as a duplicate of 6534 ***


Note You need to log in before you can comment on or make changes to this bug.