Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6334 - linuxconf random crashes and etc.
Summary: linuxconf random crashes and etc.
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: linuxconf
Version: 6.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-25 13:57 UTC by mal
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-10 19:29:52 UTC


Attachments (Terms of Use)

Description mal 1999-10-25 13:57:10 UTC
1. Linuxconf,
when runned with gnome frontend randomly
crashes with RedHat 6.1 stock installation.
Because of unknown reason it does
not work when started from gdb,
so I can not print stack trace.
To see the problem try, for example,
do a various things with PPP configuration
linuxconf will crash (sooner or later).
Same thing with many other modules.

2. When I add users by useradd
everything is OK.
But for users I added
from linuxconf --text
when such user login (or when doing su -l username)
bash prints some shell errors.
Something like
[: Too many arguments
The ~/.bashrc and the other files in home directories
are identical for users added by useradd and linuxconf.

3. When changing a password from linuxconf
when user entered a password
which is a word from a dictionary
linuxconf prints an error message (this is OK),
but then regardless this error it
asks to confirm the password.
This is slightly confusing.
If there were an error - do not ask to
confirm the password.
Just ask enter a new one.

Comment 1 Anonymous 1999-10-25 15:33:59 UTC
In addition to item 1.
linuxconf DOES NOT crash when started as
linuxconf --text
It crashes only with gnome frontend.

Comment 2 Dale Lovelace 1999-12-03 19:35:59 UTC
Tested using Linuxconf-1.16r10 which will be released as errata when testing
is completed. I would suggest upgrading when it is available.

1. Linuxconf seems to run fine under gdb. I have not seen any crashes in
testing.

2. I have added users using the gtk front end and with linuxconf --text and all
seem to be able to login with no errors.

3. Linuxconf merely returns what useradd returns. These are configurable
settings to useradd.

------- Email Received From  Vladislav Malyshkin <malyshki@cs.wmich.edu> 12/04/99 12:26 -------

Comment 3 Anonymous 1999-12-04 17:28:59 UTC
>
> +2. I have added users using the gtk front end and with linuxconf --text and
all
> +seem to be able to login with no errors.
> +

As I figured out later those login errors were caused by empty
group entry in /etc/group
The latest linuxconf probably fixes this problem.

Comment 4 nstn1291 2000-01-21 03:02:59 UTC
I tried to configure my ethernet card in order to connect to a cable modem.  I
used the gnome System Menus > System > LinuxConf to do this.

Linuxconf let me enter all the parameters, then "crashed due to a fatal error"
when I asked to activate the changes.  This is pretty frustrating!

Comment 5 Brent Fox 2002-06-05 04:43:32 UTC
Closing because we don't ship linuxconf anymore.


Note You need to log in before you can comment on or make changes to this bug.