Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6330 - installed system loads scsi modules in different order
Summary: installed system loads scsi modules in different order
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jay Turner
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-25 12:38 UTC by baz
Modified: 2015-01-07 23:39 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-10-25 15:25:11 UTC


Attachments (Terms of Use)

Description baz 1999-10-25 12:38:20 UTC
Vanilla iso, no installer updates.

Boot from cd-rom - detects 2940U2W & disk as sda - second
disk on INI-9100UW as sdb. After installation boot fails
to load root - driver modules are now loaded INI-9100 before
AIC-7xxx (thus swapping the disks).

/etc/modules.conf reads

alias scsi_hostadapter aic7xxx
alias scsi_hostadapter1 initio

I changed this to read

alias scsi_hostadapter0 aic7xxx
alias scsi_hostadapter1 initio

and recreated the initrd image. It now loads the AIC-7xxx
driver first.

Comment 1 Bill Nottingham 1999-10-25 15:25:59 UTC
This is fixed in the mkinitrd in Raw Hide.

If you'd like to work around it, change the calls to sort
in mkinitrd from:

sort -u

to

LC_ALL=C sort -u

(the en_US locale is broken...)


Note You need to log in before you can comment on or make changes to this bug.