Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 632501 - Marvell Yukon integrated ethernet controller 88E8050 problems
Summary: Marvell Yukon integrated ethernet controller 88E8050 problems
Keywords:
Status: CLOSED DUPLICATE of bug 592398
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 13
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-09-10 06:27 UTC by Panos Kavalagios
Modified: 2010-09-10 21:03 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-09-10 21:03:13 UTC


Attachments (Terms of Use)

Description Panos Kavalagios 2010-09-10 06:27:05 UTC
Description of problem: Kernel module sky2 causes kernel oops when a high
network traffic is performed.


Version-Release number of selected component (if applicable): kernel-2.6.34.6-54.fc13.x86_64


How reproducible: Under high network traffic. A big download would be fine.


Steps to Reproduce:
1. Download a big file
2. Wait a couple of minutes
3.
  
Actual results:
eth0: hw csum failure.                                                          
Pid: 0, comm: swapper Tainted: G      D    2.6.34.6-54.fc13.x86_64 #1           
Call Trace:                                                                     
 <IRQ>  [<ffffffff813a6119>] netdev_rx_csum_fault+0x3b/0x3f                     
 [<ffffffff8139fdc9>] __skb_checksum_complete_head+0x51/0x65                    
 [<ffffffff8139fdee>] __skb_checksum_complete+0x11/0x13                         
 [<ffffffff8140c80d>] nf_ip_checksum+0xdd/0xe3                                  
 [<ffffffff813ccc71>] udp_error+0x130/0x18a                                     
 [<ffffffff813c8249>] nf_conntrack_in+0x180/0x90e                               
 [<ffffffff8121693a>] ? __bitmap_weight+0x40/0x8f                               
 [<ffffffff8140ce69>] ipv4_conntrack_in+0x21/0x23                               
 [<ffffffff813c5136>] nf_iterate+0x46/0x89                                      
 [<ffffffff813d4c70>] ? ip_rcv_finish+0x0/0x362                                 
 [<ffffffff813c51e3>] nf_hook_slow+0x6a/0xcb                                    
 [<ffffffff813d4c70>] ? ip_rcv_finish+0x0/0x362                                 
 [<ffffffff813d4c70>] ? ip_rcv_finish+0x0/0x362                                 
 [<ffffffff813d5331>] NF_HOOK.clone.1+0x46/0x58                                 
 [<ffffffff813d55eb>] ip_rcv+0x256/0x283                                        
 [<ffffffff813a589e>] netif_receive_skb+0x493/0x4b9
 [<ffffffff813a6068>] napi_skb_finish+0x29/0x40
 [<ffffffff813a60ae>] napi_gro_receive+0x2f/0x34
 [<ffffffffa00f7381>] sky2_poll+0x9c5/0xc58 [sky2]
 [<ffffffff81010261>] ? sched_clock+0x9/0xd
 [<ffffffff8106b22d>] ? sched_clock_local+0x1c/0x82
 [<ffffffff813a5b4f>] net_rx_action+0xaf/0x1ca
 [<ffffffff81053265>] __do_softirq+0xe5/0x1a6
 [<ffffffff8109e0d1>] ? handle_IRQ_event+0x60/0x121
 [<ffffffff8100ab5c>] call_softirq+0x1c/0x30
 [<ffffffff8100c342>] do_softirq+0x46/0x83
 [<ffffffff810530d6>] irq_exit+0x3b/0x7d
 [<ffffffff81452a4c>] do_IRQ+0xac/0xc3
 [<ffffffff8144d193>] ret_from_intr+0x0/0x11
 <EOI>  [<ffffffff81011879>] ? mwait_idle+0x7a/0x87
 [<ffffffff8101182b>] ? mwait_idle+0x2c/0x87
 [<ffffffff81008c22>] cpu_idle+0xaa/0xe4
 [<ffffffff8143524a>] rest_init+0x7e/0x80
 [<ffffffff81baee6f>] start_kernel+0x413/0x41e
 [<ffffffff81bae2c8>] x86_64_start_reservations+0xb3/0xb7
 [<ffffffff81bae3c4>] x86_64_start_kernel+0xf8/0x107


Expected results: The ethernet controller should have worked even on high load


Additional info: This is the come back of bug 514693, duplicated to bug 574455 for Fedora 12. The workaround to restore the Internet connection is to remove sky2 module and re-insert it:

# rmmod sky2
# modprobe sky2

This is a very irritating problem following Fedora installations since Fedora 11. Downloading of a big file is nearly impossible. You have to retry several times by saving the partial content.

Comment 1 atswartz 2010-09-10 13:51:26 UTC
This looks like a hardware problem to me. 
https://bugzilla.redhat.com/show_bug.cgi?id=527110
What mobo do you have? You seem to be the only person with this problem.

Comment 2 Panos Kavalagios 2010-09-10 14:40:54 UTC
I've got an ancient Intel Desktop Board D915GEV, with a sexy Intel(R) Pentium(R) 4 CPU 3.40GHz CPU with 4 GB RAM (only 3 something the mobo sees):

http://www.intel.com/p/en_US/support/highlights/dsktpboards/d915gev

And this is my PC at work!

Comment 3 Chuck Ebbert 2010-09-10 21:03:13 UTC

*** This bug has been marked as a duplicate of bug 592398 ***


Note You need to log in before you can comment on or make changes to this bug.