Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6318 - FTP to local machine: service not available.
Summary: FTP to local machine: service not available.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tcp_wrappers
Version: 6.1
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-25 00:43 UTC by kruggiero
Modified: 2008-05-01 15:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-17 19:38:37 UTC


Attachments (Terms of Use)

Description kruggiero 1999-10-25 00:43:35 UTC
I install the machine with the "KDE Workstation" options.
When I log in as a normal user, I try to FTP to the local
host.  It connects, then hangs for a moment (without
offereing a chance for me to log in).  Then, it gives a
message: service not available, and quits.

FTP works to other sites for me.  FTP appears to be a
started service by looking at the inetd.conf file (it's not
commented out).

Comment 1 ferrelli 2000-01-03 18:08:59 UTC
I am experiencing the same problem with the same symptoms. I also have this
problem with Telnet. These utilities worked fine a few days ago and since then,
I have installed a different monitor and have worked on getting a PPP connection
up and running.

Comment 2 osman 2000-01-16 09:45:59 UTC
What does the log file "/etc/messages" say?
Also try "telnet 127.0.0.1 21" and take a note about what it says...

Comment 3 Bernhard Rosenkraenzer 2000-02-17 19:38:59 UTC
Workstation installs don't install an ftp server by default, so the behavior is
correct.
rpm -i /mnt/cdrom/RedHat/RPMS/wu-ftpd-2.6.0-1.i386.rpm should fix this.
If you want to permit anonymous access, install the anonftp RPM as well.

If you have installed wu-ftpd and anonftp, feel free to reopen this bug.


Note You need to log in before you can comment on or make changes to this bug.