Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 63123 - chkconfig <svc> always return 1 for xinetd services
Summary: chkconfig <svc> always return 1 for xinetd services
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: chkconfig
Version: rawhide
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Ben Levenson
URL:
Whiteboard:
: 84316 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-04-10 10:07 UTC by Marco Lusini
Modified: 2014-03-17 02:26 UTC (History)
2 users (show)

Fixed In Version: 1.3.14-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-02-02 21:45:54 UTC


Attachments (Terms of Use)

Description Marco Lusini 2002-04-10 10:07:37 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
Using chkconfig to see if a xinetd service is configured to be started in the 
current runlevel always returns false. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.chkconfig sendmail on
2.chkconfig telnet on
3.chkconfig sendmail ; echo $?
4.chkconfig telnet ; echo $?
	

Actual Results:  [root@iride mon]# chkconfig sendmail on
[root@iride mon]# chkconfig telnet on
[root@iride mon]# chkconfig sendmail ; echo $?
0
[root@iride mon]# chkconfig telnet ; echo $?
1


Expected Results:  [root@iride mon]# chkconfig sendmail on
[root@iride mon]# chkconfig telnet on
[root@iride mon]# chkconfig sendmail ; echo $?
0
[root@iride mon]# chkconfig telnet ; echo $?
0


Additional info:

Comment 1 Ben Levenson 2002-04-10 15:55:50 UTC
verified. should 'chkconfig <xinetd service>' look in /etc/xinetd.d/<service>
for the appropriate info? It appears to only check /etc/rc[0-6].d/

Comment 2 Bill Nottingham 2003-02-14 15:09:51 UTC
*** Bug 84316 has been marked as a duplicate of this bug. ***

Comment 3 Bill Nottingham 2005-02-02 21:45:54 UTC
Fixed in 1.3.14-1.


Note You need to log in before you can comment on or make changes to this bug.