Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6307 - restore fails to restore all files in a dump
Summary: restore fails to restore all files in a dump
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: dump
Version: 6.1
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-24 16:11 UTC by bastiaan
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-01-10 20:10:01 UTC


Attachments (Terms of Use)

Description bastiaan 1999-10-24 16:11:13 UTC
Symptoms:
Restore does not restore (some?) files that have symlinks to
them, saying instead, for example:

restore: ./etc/gtk/gtkrc.hu: cannot create special file:
Invalid argument
./etc/gtk/gtkrc.iso-8859-2: not found on tape

/etc/gtk/gtkrc.iso-8895-2 does show up when listing the dump
with restore -t, but will not be created with restore -r.

Repeat by:
dump 0f - | restore rf -

Solution:
upgrade to dump0.4b7 (I tried
http://perso.cybercable.fr/pop/dump/dump-0.4b7-1.src.rpm and
it did not exhibit the bug).

Comment 1 Niels Walet 2000-01-07 10:53:59 UTC
I have just run into similar but more serious problems under rh6.1. After a hard
disk crash I am unable to restore the file systems fully from a level 0 dump.
Files end up in the wrong place, etc. etc., many files are missing and other
problems occur as well, some related to both hard and symbolic links. I used
both versions 0.4b4 as well as 0.4b11 from the rawhide RPMS.

Comment 2 Stelian Pop 2000-01-07 11:04:59 UTC
Did you use dump 0.4b11 in order to create the dump or you were just
trying to restore an old tape (made with an older version of dump) ?

Stelian.

Comment 3 Niels Walet 2000-01-07 11:18:59 UTC
I just used it to restore the dump: It solved the symlink problem, which was
rather serious....

Comment 4 Stelian Pop 2000-01-07 11:33:59 UTC
Then it's hard to say if it's a bug in restore 0.4b11 or in the
older dump (although the tape format didn't change between
releases).

Maybe you should 0-dump your filesystem again, using the latest
version, and try to restore it. If you get any error again, please
contact my, we'll try to find the causes.

Stelian.

Comment 5 Jeff Johnson 2000-01-10 20:10:59 UTC
This problem appears to be resolved by upgrading to the latest dump in Raw Hide.
Thanks for the help.

BTW, I just built dump-0.4b12-1 in Raw Hide.


Note You need to log in before you can comment on or make changes to this bug.