Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6304 - ping no longer accepts IP addresses as >32-bit integers
Summary: ping no longer accepts IP addresses as >32-bit integers
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: iputils
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-24 13:59 UTC by jlewis
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-05-15 11:56:18 UTC


Attachments (Terms of Use)

Description jlewis 1999-10-24 13:59:55 UTC
As an easy way to do the conversion to see the dotted-quad
IP address of spammer websites posted as
http://225179979697167/, I used to use ping.  i.e.

[jlewis@sloth jlewis]$ ping 225179979697167
PING 225179979697167 (204.179.76.15): 56 data bytes

Ping from Red Hat 5.2 would take the lower 32-bits of the
number, and use it as the IP.  Red Hat 6.0 won't accept
>32-bit numbers.

In Red Hat 6.1, ping gives:

[jlewis@gsvlfl-ns-1 jlewis]$ ping 225179979697167
ping: unknown host 225179979697167

[jlewis@gsvlfl-ns-1 jlewis]$ ping 3434302479
PING 3434302479 (204.179.76.15) from 209.208.0.2 : 56(84)
bytes of data.

Comment 1 Pekka Savola 2000-07-12 16:32:35 UTC
I could not reproduce this on a Redhat 5.2 system (+all updates) running 2.2.16,
or recompiled on a newer system, so I guess this is an issue with libraries/headers.

Nonetheless, I don't think this kind of broken behaviour should be supported.
This won't work in other newer systems anymore either (e.g. FreeBSD 4.0).




Note You need to log in before you can comment on or make changes to this bug.