Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6300 - / is not remounted readonly while shutdowning if quotas are active on it
Summary: / is not remounted readonly while shutdowning if quotas are active on it
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-24 08:47 UTC by Olivier Benghozi
Modified: 2014-03-17 02:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-10-25 17:16:39 UTC


Attachments (Terms of Use)

Description Olivier Benghozi 1999-10-24 08:47:46 UTC
Root filesystem / is not remounted readonly before the
effective reboot or shutdown if quotas are active on it,
causing an fsck at each system start.

Normally, /etc/rc.d/init.d/halt contains a
mount -n -o remount,ro /
that seemed to work well in RH6.0, but it seems that now,
quota must be stopped before trying to put / in ro.

Messages are:

mount: / is busy
and then again the same message, caused by "remounting
remaining FS readonly" in the halt script.

So before
mount -n -o remount,ro /
I added a line:
quotaoff -a

It seems to work.
Maybe an initscripts fix should be released, I know of
people that had corrupted datas because of that.

Comment 1 Bill Nottingham 1999-10-25 17:16:59 UTC
Fixed in initscripts-4.58, will be in next Raw Hide release.


Note You need to log in before you can comment on or make changes to this bug.