Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 627887 - [NM][ALL Lang] The same Shortcut keys in "select Mobile Broadband Provider Type" screen.
Summary: [NM][ALL Lang] The same Shortcut keys in "select Mobile Broadband Provider Ty...
Keywords:
Status: CLOSED DUPLICATE of bug 589230
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: NetworkManager
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Dan Williams
QA Contact: QE Internationalization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-27 09:52 UTC by cshao
Modified: 2010-10-18 16:57 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-09-20 19:31:56 UTC
Target Upstream Version:


Attachments (Terms of Use)
same shortcut keys (deleted)
2010-08-27 09:53 UTC, cshao
no flags Details

Description cshao 2010-08-27 09:52:18 UTC
Description of problem:
The same Shortcut keys (Cancel and CDMA) in "select Mobile Broadband Provider Type" screen.

Version-Release number of selected component (if applicable):
RHEL6.0-Snapshot-12 X86_64


How reproducible:
100%

Steps to Reproduce:
1.Click Configure Network button.
2.Click Mobile Broadband tab.
3.Click Add button.
4.The same Shortcut keys (Cancel and CDMA) appears.
  
Actual results:
The same Shortcut keys (Cancel and CDMA) in "select Mobile Broadband Provider Type" screen.

Expected results:
Set different Shortcut keys.

Additional info:

Comment 1 cshao 2010-08-27 09:53:51 UTC
Created attachment 441453 [details]
same shortcut keys

Comment 3 cshao 2010-08-27 10:18:04 UTC
The shortcut keys is "Alt + C".

Comment 4 Chris Lumens 2010-08-27 13:06:21 UTC
We're using the stock gtk-cancel button there, so it's going to have to be up to NM to change what shortcut key they are using.

Comment 5 koka xiong 2010-08-30 03:50:48 UTC
I install by zh-CN GUI on snapshot 12 of RHEL6, it has the same problem:
the same Shortcut keys (Cancel and CDMA) in "select Mobile Broadband Provider
Type" screen.
1.Click Configure Network button.
2.Click Mobile Broadband tab.
3.Click Add button.
4.The same Shortcut keys (Cancel and CDMA) appears.

Comment 6 A S Alam 2010-08-30 05:40:51 UTC
POT file has strings
#: ../src/connection-editor/page-mobile.c:611
msgid "My provider uses _CDMA-based technology (i.e. 1xRTT, EVDO)"

Comment 7 cshao 2010-09-01 03:54:57 UTC
I test in Red Hat Enterprise Linux Workstation release 6.0 Beta-2 (Santiago) and Rhel6 Snapshot 11, this bug also exist. So this bug isn't a regression bug.

Comment 8 Jirka Klimes 2010-09-02 12:36:25 UTC
Fixed in upstream:
0aef6898cf09040352d9b75143638cd34b9e2ef0 (master)
09ff23c4134aaa5fb06087b74fcfb14bedc1c6af (NMA_0_8)

Accelerator key 'C' changed to 'D'.

Comment 9 A S Alam 2010-09-02 13:25:19 UTC
Verified: upstream POT file updated
--
#: ../src/connection-editor/page-mobile.c:609
msgid "My provider uses C_DMA-based technology (i.e. 1xRTT, EVDO)"
msgstr ""
--

i18n Issue is FIXED it need to Fix in translation, which are tracked by another bug for 6.1 bug #589230

Closing This bug

Comment 10 Jirka Klimes 2010-09-02 15:12:33 UTC
Translations updated in upstream as well:
d87c89cb8ce85e012d67e38a09996dd44f291a43 (master)
91ce0bf3fb5606783ea66588e6f19ba6e864a4d5 (NMA_0_8)

Comment 11 Suzanne Yeghiayan 2010-09-20 19:31:56 UTC

*** This bug has been marked as a duplicate of bug 589230 ***


Note You need to log in before you can comment on or make changes to this bug.