Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6254 - ping -c / -w # don't work as needed
Summary: ping -c / -w # don't work as needed
Keywords:
Status: CLOSED DUPLICATE of bug 8724
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: netkit-base
Version: 6.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-22 17:03 UTC by jrjohns
Modified: 2008-05-01 15:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-01-27 20:05:27 UTC


Attachments (Terms of Use)

Description jrjohns 1999-10-22 17:03:15 UTC
This bug is related to these other bugs:  3959, 6160.

Alexey Kuznetsov has recently posted a new copy of his
iputils package from which RedHat's 'ping' is taken.
Located at ftp://ftp.inr.ac.ru/ip-routing/, the package is
named iputils-ss991015.tar.gz.  This update fixes a bug with
the new -w # (timeout) option which exists in the Red Hat
6.1 release but doesn't work as advertised in the man page.

A little history:  Bug 3959 filed against Red Hat 6.0
reported that "ping -c #" no longer exits when pinging a
down host, and this was marked as resolved in the next
release.  Alexey apparently introduced the -w option to
compensate for this same problem, but in Red Hat 6.1, the -w
command does not work as intended due to a bug in the code.
As a result, ping still never exits when talking to a down
host.  Bug 6160, also filed against Red Hat 6.0, appears
to be a duplicate of 3959.

There are two possible solutions to this bug in Red Hat 6.1:
One is to install the new ping with the working -w option;
the other is to look into fixing -c properly.

I find it curious that -w was added rather than fixing -c
to exit when a host is not responding, thereby keeping
things compatible with existing software that expects ping
to behave in a certain way, but I suppose this matter would
have to be taken up with Mr. Kuznetsov.

Comment 1 Jeff Johnson 2000-01-27 20:05:59 UTC
*** This bug has been marked as a duplicate of 8724 ***


Note You need to log in before you can comment on or make changes to this bug.