Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6252 - wrong paths to ipx_interface in ifup-ipx
Summary: wrong paths to ipx_interface in ifup-ipx
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts
Version: 6.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
: 6301 6606 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-22 16:55 UTC by martin
Modified: 2014-03-17 02:10 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-10-22 21:15:02 UTC


Attachments (Terms of Use)

Description martin 1999-10-22 16:55:45 UTC
The scripts ifup-ipx calls (and seeks) the ipx_interface
program in /usr/bin although it is installed in /sbin.

Fix is trivial: just replace /usr/bin/ipx_interface by
/sbin/ipx_interface

Comment 1 Bill Nottingham 1999-10-22 21:15:59 UTC
Fixed in initscripts-4.57-1, will be in next Raw Hide release.

Comment 2 Bill Nottingham 1999-10-25 15:51:59 UTC
*** Bug 6301 has been marked as a duplicate of this bug. ***

bash# rpm -q ipxutils
ipxutils-2.2.0.16.a-1
bash# rpm -ql ipxutils |grep ipx_interface
/sbin/ipx_interface
^^^^^^^^^^^^^^^^^^
/usr/man/man8/ipx_interface.8
bash# grep -2 ipx_interface /etc/sysconfig/network-scripts/ifup-ipx|head -5
fi

if [ ! -x /usr/bin/ipx_interface ] ; then
          ^^^^^^^^^^^^^^^^^^^^^^
        # cannot configure IPX with non-existant utilities
        exit 0
bash# rpm -qf /etc/sysconfig/network-scripts/ifup-ipx
initscripts-4.48-1

Comment 3 Bill Nottingham 1999-11-01 17:37:59 UTC
*** Bug 6606 has been marked as a duplicate of this bug. ***

Hi,

In ifup-ipx there is a line:

if [ ! -x /usr/bin/ipx_interface ] ; then

This line is wrong, the ipxutils package puts this file in
/sbin... so the line should be:

if [ ! -x /sbin/ipx_interface ] ; then

Chris


Note You need to log in before you can comment on or make changes to this bug.