Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6245 - newly added users don't have 'group' assigned to them
Summary: newly added users don't have 'group' assigned to them
Keywords:
Status: CLOSED DUPLICATE of bug 6089
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: linuxconf
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-22 15:08 UTC by wayland_chan
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-12-02 18:50:10 UTC


Attachments (Terms of Use)

Description wayland_chan 1999-10-22 15:08:50 UTC
I added several users in 6.0 before upgrading to 6.1. Then I
proceeded to add some more users (using
linuxconf-1.16r3.2-2) when I noticed that the newly added
users don't have a default group assigned.

In 6.0, if I added a user 'wchan'. That account would have
group 'wchan' as well.

/etc/group has 2 lines which for the newly added users (6.1
with no groups)...

:*:508:
:*:509:


I used linuxconf to modify the 2 users, I added groups for
them (same as their userid). Now my /etc/group looks like...

:*:508:
:*:509:
macarta:*:510:
xuem:*:511:


Is this a bug?

Thanks....great job on 6.1. The /upgrade install was slick.


Wayland Chan

Comment 1 kresa 1999-11-03 17:17:59 UTC
it is a bug, since it breaks /etc/csh.login, line:
[ `id -gn` = `id -un` -a `id -u` -gt 14]
fails, and then the /etc/profile.d stuff doesn't get executed
if login shell is tcsh

Comment 2 jack 1999-11-30 17:20:59 UTC
This was fixed in 1.16r7

Comment 3 Michael K. Johnson 1999-12-02 18:50:59 UTC
Our next errata release of linuxconf (after we finish testing) should
fix this.

*** This bug has been marked as a duplicate of 6089 ***


Note You need to log in before you can comment on or make changes to this bug.