Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 624 - Perl's socket.ph is broken
Summary: Perl's socket.ph is broken
Keywords:
Status: CLOSED DUPLICATE of bug 90
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: perl
Version: 5.2
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1998-12-27 11:46 UTC by tmb-redhat
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1998-12-31 15:18:20 UTC


Attachments (Terms of Use)

Description tmb-redhat 1998-12-27 11:46:52 UTC
Requiring "sys/socket.ph" results in an error.
This breaks some Perl scripts.

sonata$ perl -e 'require "sys/socket.ph";'
Prototype mismatch: sub main::__need_size_t vs () at (eval
43) line 1.
String found where operator expected at (eval 147) line 1,
near "&__const 'struct sockaddr'"
        (Missing operator before  'struct sockaddr'?)
sonata$

This is on a RedHat 5.2 system upgraded from RedHat 5.1.
I verified the Perl installation with rpm --verify.

Comment 1 Jeff Johnson 1998-12-31 15:18:59 UTC
*** This bug has been marked as a duplicate of 90 ***


Note You need to log in before you can comment on or make changes to this bug.