Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 622441 - AttributeError while handling function satexport._wrapper
Summary: AttributeError while handling function satexport._wrapper
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Other
Version: 540
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Michael Mráka
QA Contact: Šimon Lukašík
URL:
Whiteboard:
Depends On:
Blocks: sat540-canfix
TreeView+ depends on / blocked
 
Reported: 2010-08-09 11:21 UTC by Šimon Lukašík
Modified: 2010-10-28 14:48 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-10-28 14:48:05 UTC
Target Upstream Version:


Attachments (Terms of Use)
root's mailbox (deleted)
2010-08-09 11:21 UTC, Šimon Lukašík
no flags Details

Description Šimon Lukašík 2010-08-09 11:21:11 UTC
Created attachment 437569 [details]
root's mailbox

Description of problem:
Well, there are tracebacks sent by mail by rhn-satellite-exporter. These are deterministic and reproducer by /CoreOS/RHN-Satellite/Inter-Satellite-Sync/Multihost/general



Exception Handler Information
Traceback (most recent call last):
  File "/usr/share/rhn/satellite_exporter/satexport.py", line 103, in _wrapper
    ret = function(req)
  File "/usr/share/rhn/satellite_exporter/satexport.py", line 169, in _handler
    result = f(*params)
  File "/usr/share/rhn/satellite_exporter/handlers/non_auth_dumper.py", line 468, in channel_families
    return self.dump_channel_families()
  File "/usr/share/rhn/satellite_exporter/handlers/non_auth_dumper.py", line 291, in dump_channel_families
    d.dump()
  File "/usr/share/rhn/satellite_tools/exporter/exportLib.py", line 65, in dump
    self._attributes = self.set_attributes() or {}
  File "/usr/share/rhn/satellite_tools/disk_dumper/dumper.py", line 543, in set_attributes
    attributes['generation'] = CFG.SAT_CERT_GENERATION
  File "/usr/share/rhn/common/rhnConfig.py", line 356, in __getattr__
    raise AttributeError(key)
AttributeError: SAT_CERT_GENERATION


There is missing code for rhnConfig.RHNOptions.__getattr__(SAT_CERT_GENERATION), which is called.


Version-Release number of selected component (if applicable):
SW-nightly(2010-08-06) on Fedora-12

How reproducible:
always

Steps to Reproduce:
1. 
2.
3.
  
Actual results:
traceback in mail

Expected results:
no traceback

Additional info:

Comment 5 Šimon Lukašík 2010-09-07 11:33:20 UTC
Today, I cannot reproduce this bug neither on SW-nightly nor on Sat540.

Comment 7 Šimon Lukašík 2010-09-08 07:59:03 UTC
Changing to VERIFIED:

As per comments 5 and 6, I cannot reproduce this issue with latest available SW/Sat versions.

Comment 8 Miroslav Suchý 2010-10-25 11:34:22 UTC
verified in stage in beaker (j:25917)

Comment 9 Clifford Perry 2010-10-28 14:43:22 UTC
The 5.4.0 RHN Satellite and RHN Proxy release has occurred. This issue has been resolved with this release. 


RHEA-2010:0801 - RHN Satellite Server 5.4.0 Upgrade
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10332

RHEA-2010:0803 - RHN Tools enhancement update
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10333

RHEA-2010:0802 - RHN Proxy Server 5.4.0 bug fix update
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10334

RHEA-2010:0800 - RHN Satellite Server 5.4.0
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10335

Docs are available:

http://docs.redhat.com/docs/en-US/Red_Hat_Network_Satellite/index.html 

Regards,
Clifford


Note You need to log in before you can comment on or make changes to this bug.