Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6221 - linuxconf coredump when moving $HOME
Summary: linuxconf coredump when moving $HOME
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: linuxconf
Version: 6.0
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
: 6222 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-22 04:23 UTC by thomas
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-01-17 13:34:33 UTC


Attachments (Terms of Use)

Description thomas 1999-10-22 04:23:52 UTC
Linux = every time you press a key,a new bug appears ! A
free system, bust an incalculable lost of time

The last bug encoutered = impossibilitie to move an user
directory.

What I have done:
 - move my home directory from /home/xxx to /users/xxx
 - register the new home directory using linuxconf

What appened:
 - core file cerated by linuxconf
 - lost of all configuration file when I log on.
 - xterm is always started in the .gnome.desktop directory
 - A CORE (10 Mb) IS  CREATED EACH TIME I LOG ON !!!

See you soon !

Comment 1 Bill Nottingham 1999-10-22 14:36:59 UTC
*** Bug 6222 has been marked as a duplicate of this bug. ***

Linux = every time you press a key,a new bug appears ! A
free system, bust an incalculable lost of time

The last bug encoutered = impossibilitie to move an user
directory.

What I have done:
 - move my home directory from /home/xxx to /users/xxx
 - register the new home directory using linuxconf

What appened:
 - core file cerated by linuxconf
 - lost of all configuration file when I log on.
 - xterm is always started in the .gnome.desktop directory
 - A CORE (10 Mb) IS  CREATED EACH TIME I LOG ON !!!

See you soon !

Comment 2 Dale Lovelace 1999-12-03 19:21:59 UTC
I just tried this.

useradd user
passwd user
Changing password for user user
New UNIX password: xxxxxx
Retype new UNIX password: xxxxxx
passwd: all authentication tokens updated successfully

mv /home/user /tmp/user
linuxconf --> Users Accounts/Normal --> User Accounts --> Select User
Change the line "Home Directory(opt)" to /tmp/user
exit Linuxconf
login as "user"

  All is fine. This was with Linuxconf-1.16r10 which will be released as errata
when testing is completed. I would suggest upgrading when available.

Comment 3 Nalin Dahyabhai 2000-01-17 13:34:59 UTC
This is likely because GNOME (and most programs like Netscape Navigator, ncftp,
etc.) will record the location of your home directory in its configuration
files, and there's no way for linuxconf to know where it needs to modify your
configuration files and where it should leave things alone.  The most workable
solution is probably to manually edit the list of files you get from:
grep -l /home/oldhomedir `find -type f`

The simplest solution is to just remove the offending configuration files and
let the various programs reset to their defaults.

Comment 4 Brent Fox 2002-06-05 04:40:11 UTC
Closing because we don't ship linuxconf anymore.


Note You need to log in before you can comment on or make changes to this bug.