Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6217 - installer crashes when finding NT partition
Summary: installer crashes when finding NT partition
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.1
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Jay Turner
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-22 02:44 UTC by randy.schrickel
Modified: 2015-01-07 23:39 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-10-22 16:26:01 UTC


Attachments (Terms of Use)

Description randy.schrickel 1999-10-22 02:44:51 UTC
Similar to many other bugs entered on the installer - begs
the questions - was the installer ever tested and _when_
will they be fixed so I can finish my upgrade?

Upgrading from 6.0 to 6.1 from local hard disk.

Get to the point of the dialog with "Searching for..." after
selecting a device and directory to install from. Get the
messages:

Error mounting ext2 filesystem on sda1: Invalid argument

Then the traceback:

/usr/bin/anaconda.real line 225 in ?
  intf.run (todo, test = test)
/tmp/lib/python1.5/site-packages/text.py line 1000 in run
  rc = apply(step[1](), step[2])
/tmp/lib/python1.5/site-packages/text.py line 222 in
__call__
  parts = todo.upgradeFindRoot()
/tmp/lib/python1.5/site-packages/todo.py line 1130 in
upgradeFindRoot
  isys.umount('/mnt/sysimage')
/tmp/lib/python1.5/site-packages/isis.py line 8 in umount
  return _isys.umount(what)
SystemError = (22, 'Invalid Argument')

install exited abnormally....
you may safely reboot...

The disk it was trying to mount - sda1 - is *not* an ext2
partition, it's an NT partition.

Comment 1 Bill Nottingham 1999-10-22 14:37:59 UTC
*** This bug has been marked as a duplicate of 5677 ***

Comment 2 Bill Nottingham 1999-10-22 16:26:59 UTC
*** This bug has been marked as a duplicate of 5567 ***


Note You need to log in before you can comment on or make changes to this bug.