Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 618640 - [abrt] crash in system-config-printer-1.2.3-3.fc13: system-config-printer.py:6059:getDeviceURI:AttributeError: 'NoneType' object has no attribute 'type'
Summary: [abrt] crash in system-config-printer-1.2.3-3.fc13: system-config-printer.py:...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer
Version: 13
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:c321904e
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-27 12:46 UTC by zaterio
Modified: 2011-02-03 17:08 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-02-03 17:08:27 UTC


Attachments (Terms of Use)
File: backtrace (deleted)
2010-07-27 12:46 UTC, zaterio
no flags Details

Description zaterio 2010-07-27 12:46:48 UTC
abrt 1.1.1 detected a crash.

architecture: i686
cmdline: python /usr/share/system-config-printer/system-config-printer.py
component: system-config-printer
executable: /usr/share/system-config-printer/system-config-printer.py
kernel: 2.6.33.6-147.fc13.i686
package: system-config-printer-1.2.3-3.fc13
reason: system-config-printer.py:6059:getDeviceURI:AttributeError: 'NoneType' object has no attribute 'type'
release: Fedora release 13 (Goddard)

backtrace
-----
system-config-printer.py:6059:getDeviceURI:AttributeError: 'NoneType' object has no attribute 'type'

Traceback (most recent call last):
  File "/usr/share/system-config-printer/system-config-printer.py", line 4366, in on_btnNPForward_clicked
    self.nextNPTab()
  File "/usr/share/system-config-printer/system-config-printer.py", line 4379, in nextNPTab
    self.device.uri = self.getDeviceURI()
  File "/usr/share/system-config-printer/system-config-printer.py", line 6059, in getDeviceURI
    type = self.device.type
AttributeError: 'NoneType' object has no attribute 'type'

Local variables in innermost frame:
self: <__main__.NewPrinterGUI instance at 0xa285a4c>

How to reproduce
-----
1. Try to install a network printer
2.
3.

Comment 1 zaterio 2010-07-27 12:46:50 UTC
Created attachment 434681 [details]
File: backtrace

Comment 2 Jiri Popelka 2010-07-27 16:53:45 UTC
Are you able to reproduce the crash ?
If so can you describe exact steps that lead to the crash.
I'm not able to figure out what has happened.
Thank you

Comment 3 zaterio 2010-08-07 18:08:38 UTC
Not able to reproduce crash.
I add the printer again and the error was not present.
Regards.

Comment 4 Tim Waugh 2011-02-03 17:08:27 UTC
I haven't found a way to reproduce this.  self.device is set whenever a device is selected from the list, and the Forward button is not clickable until a device has been selected.


Note You need to log in before you can comment on or make changes to this bug.