Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6181 - restore opens the device files it's restoring
Summary: restore opens the device files it's restoring
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: dump
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-21 09:00 UTC by Chris Siebenmann
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-10-21 09:00:04 UTC


Attachments (Terms of Use)

Description Chris Siebenmann 1999-10-21 09:00:04 UTC
A 'restore rf' (and probably other restore operations)
appears to open the devices it is restoring to do, well,
something. This is easily reproduced with:
	# cd /scratch/dir; dump 0f - / | restore rf -
and watch the pretty kernel messages.

 Opening devices can have very dangerous consequences,
such as rewinding tape drives or worse, and I believe
that restore should not be doing this.

 This behavior is new in the 6.0 restore; the 5.2 restore
does not have this problem.

 I suspect that this behavior persists in 6.1, but because
of 6.1's restore-symlink problem (bug #5923, I believe)
I couldn't really run a test of this.


Note You need to log in before you can comment on or make changes to this bug.