Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6177 - minor problem in sox package, link for 'rec' man page is wrong.
Summary: minor problem in sox package, link for 'rec' man page is wrong.
Keywords:
Status: CLOSED DUPLICATE of bug 5669
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sox
Version: 6.1
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-21 04:58 UTC by Jeff Norden
Modified: 2014-03-17 02:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-10-21 17:37:51 UTC


Attachments (Terms of Use)

Description Jeff Norden 1999-10-21 04:58:51 UTC
This is minor, but after upgrading from 6.0 to 6.1 the
symbolic link for the 'rec' man page was broken.

In /usr/man/man1, I had

lrwxrwxrwx   1 root     root           37 Oct 17 21:24
           rec.1 -> /var/tmp/sox-root/usr/man/man1/play.1

(the above should be read as all one line).

----

The interesting thing is that this manifested itself a week
later in mail to root about the failure of run-parts on
cron.weekly.  The entire message was:

  From: root@norden.math.tntech.edu (Cron Daemon)
  To: root@norden.math.tntech.edu
  Subject: Cron <root@norden> run-parts /etc/cron.weekly

  Read file error: ./rec.1 No such file or directory

This also points up a weakness in /usr/sbin/makewhatis, in
that it doesn't do a very good job of error reporting.  It
doesn't even report its own name (so I had to start by
looking in cron.weekly) nor does it report the full path to
the offending file.


Hope this helps.  Let me know if you'd like me to submit a
patch and I'll work one up for you.

Comment 1 Bill Nottingham 1999-10-21 17:37:59 UTC
*** This bug has been marked as a duplicate of 5669 ***


Note You need to log in before you can comment on or make changes to this bug.