Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6159 - FTP/HTTP/hard drive installs crash if non *.rpm files exist
Summary: FTP/HTTP/hard drive installs crash if non *.rpm files exist
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.1
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Matt Wilson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-20 18:36 UTC by Jay Turner
Modified: 2015-01-07 23:39 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-21 21:33:49 UTC


Attachments (Terms of Use)

Description Jay Turner 1999-10-20 18:36:38 UTC
These install methods will lead to crashes (python
exceptions) if there are files in the /RedHat/RPMS directory
which are not valid RPM files, or are misspelled files.
Installer should really handle this a little better.  Best
case of this is when retrieving files from CDROM and getting
the TRANS.TBL file, or when using WSFTP and getting the ftp
log in the directory.

Comment 1 johna 1999-10-21 03:10:59 UTC
I am seeing the same crashes as per 5618, 5875, 5546, 5551, and 5615.

My system has only formatted FAT32/VFAT and formatted ext2 partitions.
The rpms directory is on one of the FAT32 partitions. Running "ls -a |
grep -v rpm" shows that the only non-RPM entries in this directory are
"." and "..".

------- Additional Comments From   11/07/99 16:02 -------
This is a real nuisance if you downloaded redhat form a mirror
site that automatically creates ls-lR files.

Please, when writing utilities like anaconda, include diagnostics. If
there was a filename with the error, I could have figured it out.

Comment 2 Jay Turner 1999-11-09 15:35:59 UTC
*** Bug 6808 has been marked as a duplicate of this bug. ***

I upgraded my Redhat 6.0 system from local hard drive.
Somehow, when I was ftping all the RPMs a few went missing,
and so my copy of Red Hat was incomplete. The upgrade
script crashed in a confusing way, throwing
incomprehensible Python stack trace. It would have been
more helpful to have an English error message.

I believe this bug is in the same general class as #6159: a
corrupted RPM repository not handled gracefully by the
installer.

Comment 3 eschmenk 1999-12-01 17:06:59 UTC
I think that this is something that should be mentioned on the 6.1 gotchas
page.  It certainly is one!

Comment 4 Jay Turner 2000-02-21 21:33:59 UTC
This issue is resolved in the latest beta.


Note You need to log in before you can comment on or make changes to this bug.