Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 61413 - RFE: Can't replace a directory with a symlink
Summary: RFE: Can't replace a directory with a symlink
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact:
URL:
Whiteboard:
: 3979 (view as bug list)
Depends On:
Blocks: 61131 73500 79579 CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2002-03-19 10:55 UTC by Bernhard Rosenkraenzer
Modified: 2007-04-18 16:41 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-29 18:14:56 UTC


Attachments (Terms of Use)

Description Bernhard Rosenkraenzer 2002-03-19 10:55:23 UTC
Description of Problem: 
rpm can't replace a directory with a symlink. 
 
Version-Release number of selected component (if applicable): 
4.0.4-7x.5 
 
How Reproducible: 
100% 
 
Steps to Reproduce: 
1. Build an rpm with a directory in it; install it 
2. Update the rpm, replacing the directory with a symlink 
3. Try to upgrade to the new rpm 
 
Actual Results: 
Error messages, failed upgrade 
 
Expected Results: 
New rpm is installed 
 
Additional Information: 
I know it's always been that way; filing a bug report in the hopes of getting it on the 
feature list for one of the next versions. 
 
This issue blocks fixing some other bugs.

Comment 1 Jeff Johnson 2002-07-20 18:55:19 UTC
*** Bug 3979 has been marked as a duplicate of this bug. ***

Comment 2 Paul Nasrat 2005-09-29 18:14:56 UTC
We're not looking at doing this anytime soon.  If you want this persued probably
best forum is rpm-devel list

https://lists.dulug.duke.edu/mailman/listinfo/rpm-devel


Note You need to log in before you can comment on or make changes to this bug.