Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6141 - Bad entries in /etc/fstab will kill anaconda
Summary: Bad entries in /etc/fstab will kill anaconda
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.1
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Erik Troan
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-20 15:33 UTC by Neal D. Becker
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-24 19:02:10 UTC


Attachments (Terms of Use)

Description Neal D. Becker 1999-10-20 15:33:52 UTC
A bad entry /tmp/swap in /etc/fstab kills anacoda:

Traceback:
[...]
File "/usr/lib/python1.5/site-packages/isys.py",
line 64, in makeDevInode
return _isys.mkdevinode(name,fn)
SystemError:(2, 'No such file or directory')

The python error message doesn't even give the user a clue what's
wrong!  Luckily, I found the problem.  (I had previously had a /tmp/swap
swap file, but had removed it).

Comment 1 Jay Turner 1999-12-06 15:13:59 UTC
*** Bug 5019 has been marked as a duplicate of this bug. ***

Comment 2 Erik Troan 2000-02-24 18:15:59 UTC
Fixed for next release.


Note You need to log in before you can comment on or make changes to this bug.