Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6136 - domaintable feature not included
Summary: domaintable feature not included
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sendmail
Version: 6.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-20 13:41 UTC by chris
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-05 05:08:29 UTC


Attachments (Terms of Use)

Description chris 1999-10-20 13:41:17 UTC
The default sendmail.cf file no-longer seems to include the
'domaintable' feature, even though the sendmail package
includes /etc/mail/domaintable.

It seems to have gone missing from the redhat.c4 file
completely for the 6.1 distro.

Comment 1 tom 1999-12-16 22:34:59 UTC
I can confirm that sendmail-8.9.3-10 (RH6.0) and sendmail-8.9.3-15 (RH6.1) were
both missing the domaintable entry in /etc/sendmail.mc and related section of
/etc/sendmail.cf.

I added FEATURE(`domaintable',`hash -o /etc/mail/domaintable') to sendmail.mc
and rebuilt the sendmail.cf.  According to a document I read on sendmail.org,
the default location of the domaintable is /etc/domaintable, so you have to
include the second parameter.

Note that there's a typo in line 3 of the sendmail.mc: thie ->

Comment 2 Cristian Gafton 2000-02-05 05:08:59 UTC
This is a sysadmin issue. We can not be possibly turning on all the features
sendmail has to offer. The site admin is responsible for configuring the extra
features.

It would be cool toi have a config tool, but until then...

Comment 3 chris 2000-02-05 11:40:59 UTC
The issue isn't that 'domaintable' is simply missing. I can appreciate that you
can't, and probably shouldn't, turn on every possible feature.

The issue is that it USED TO BE enabled in at least redhat-5.2, and is no-
longer enabled. You will be getting issues with folk that have used domaintable
in redhat-5.2, but when they upgrade to redhat-6.1 (as all good redhatians
should, yes?? ;) something will stop working. That's gonna be a very hairy one
to figure out for those folk. (Not everyone's a sendmail guru ;)


Note You need to log in before you can comment on or make changes to this bug.