Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6130 - Disk Druid problems, esp. with Solaris
Summary: Disk Druid problems, esp. with Solaris
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jay Turner
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-20 09:18 UTC by arb
Modified: 2015-01-07 23:39 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-10-22 13:52:43 UTC


Attachments (Terms of Use)

Description arb 1999-10-20 09:18:37 UTC
The X-Window Disk Druid has a few problems:

1) It doesn't recognise Solaris partitions.  Naughty!
It sees them as Linux Swap which is fair enough given that
they have the same partition id, but then there is no way
to change the mount point from <swap> to <not set>.  I don't
want to overwrite Solaris data with Linux swap.  The current
workaround is to use a partition manager to fake the id of
the solaris partition as something else during the Linux
installation.

2) The installer refuses to show a Next button until a
swap partition is defined.  I don't want one since I have
128M RAM.  I use Solaris x86 fine without a swap partition!

3) I can't define a root "/" partition greater than 1882M.
Why not?  It just complains "root partition too big".

Comment 1 Jay Turner 1999-10-20 14:54:59 UTC
We were hoping that we had fixed problem #1, but apparently we did
not.  Sorry about that . . . we will put it in the list for next
release.

You should be able to install in expert mode (type "expert" at the
boot prompt) and that should allow you to get past the requirement of
having a swap partition.  The other option is to create a 1M swap
partition and just delete it after you reboot the machine (remember to
remove it from /etc/fstab as well)

Problem #3 is a confusing situation, but what is really happening is
that the installer is trying to tell you that the BIOS on your
computer will not allow booting from a partition which is not within
the first 1024 sectors of the drive.  The best way to get around this
it to create a small (16-32M) /boot partition and then create your
root partition.  With this setup, the installer will let you create as
large a root partition as your drives will handle.

Comment 2 Jay Turner 1999-10-22 13:52:59 UTC
*** This bug has been marked as a duplicate of 5539 ***


Note You need to log in before you can comment on or make changes to this bug.