Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6116 - IP Aliases not working
Summary: IP Aliases not working
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: netcfg
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-20 04:16 UTC by jim
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-10-20 04:43:33 UTC


Attachments (Terms of Use)

Description jim 1999-10-20 04:16:12 UTC
When upgrading from RH 6.0 to RH 6.1 ...
The next thing I noticed was that my "IP Aliases for Virtual
Host" no longer worked.  It turns out the scripts are broken
and can't handle ranges of IP addresses (i.e.
208.34.16.194-222).  There amy also be other problems with
it, I don't know.  My fix for this may not have been the
best, but I was running out of time.  Anyway, my fix was to:

1) Save the contents of the /etc/sysconfig/network-scripts
directory (actually I just renamed it to
/etc/sysconfig/network-scripts.RH61).

2)Extract the contents of the /etc/sysconfig/network-scripts
directory from my last backup.

3) Copy the network-functions file from the new RH61
distribution into the newly extracted directory.

4) Issue the following command.
/etc/rc.d/init/network restart

Comment 1 Bill Nottingham 1999-10-20 04:43:59 UTC
Grab the latest initscripts from Raw Hide; this should solve the problem.


Note You need to log in before you can comment on or make changes to this bug.