Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6103 - ypbind does not find users properly
Summary: ypbind does not find users properly
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ypbind
Version: 6.1
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-19 21:56 UTC by adler
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-04 02:39:00 UTC


Attachments (Terms of Use)

Description adler 1999-10-19 21:56:32 UTC
I just had a strange insident. A user came by complaining
that he
couldn't log into one of our linux boxes. All of them use
NIS which
is served from an SGI system running IRIX 5.3. I tried doing
an
su - username and got the error that the username was not a
valid
one.(the extact text of the mssage was "su: user username
does not exist")
But it did work on the other linux boxes. I then restarted
ypbind
(i.e.

  cd /etc/rc.d/init.d
  ./ypbind restart

)

and the su command worked. Before doing the ypbind restart,
I did try
out one other account and the su into that account did work.

If this happens again, is there a better way of diagnosing
the problem?

Steve.

Comment 1 Cristian Gafton 2000-02-04 02:39:59 UTC
ypbind takes a while (~1min) to detect that an NIS server is down and to connect
to another one, and then if and only if the /etc/yp.conf permits broadcasting
for a certain domain


Note You need to log in before you can comment on or make changes to this bug.