Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6085 - Empty passwords don't work correctly if not using shadow
Summary: Empty passwords don't work correctly if not using shadow
Keywords:
Status: CLOSED DUPLICATE of bug 3029
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: pwdb
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-19 15:18 UTC by Chaskiel Grundman
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-10-19 16:13:08 UTC


Attachments (Terms of Use)

Description Chaskiel Grundman 1999-10-19 15:18:03 UTC
If shadow passwords are not being used on a system, the
following things do not seem to work properly

1) logging in if you have an empty password. pam_pwdb
reports 'get passwd; pwdb: request not recognized' in syslog
2) changing  or deleting the password of an entity that
currently does not have a password (either an 'empty
password' or 'no password'). passwd reports success, but the
contents of /etc/passwd are not changed

Comment 1 Bill Nottingham 1999-10-19 16:13:59 UTC
*** This bug has been marked as a duplicate of 3029 ***


Note You need to log in before you can comment on or make changes to this bug.